夜空日和 [出張版]

星を見上げながら、今日を語ってみようか

 

スポンサーサイト


Category: スポンサー広告   Tags: ---
上記の広告は1ヶ月以上更新のないブログに表示されています。
新しい記事を書く事で広告が消せます。

eclipse / tomcat のエラー


Category: 技術   Tags: ---
ふと思い立って、苦手なwebアプリを始めようと思ったのが夏休み初め。
それから、本借りて、開発環境を整えて、開発を始めて。

・・・と問屋は卸さない訳で。
世の中、上手くいかないものです。


導入したtomcatが、eclipse上から起動しない。
eclipseから起動できるようにすれば、eclipse画面からJSPの結果を簡単に見れるので楽なのに・・・
xamppでapatchとtomcatを一括で入れて、単体起動は確認したんだけどなぁ~。


エラー1:
java.lang.UnsatisfiedLinkError: org.apache.tomcat.jni.Pool.create(J)J

これの解決に1週間かかった。
内容的に、JNI が入ってるから、ネイティブライブラリが見つからないエラーかなと推察。
xampp内の DLLやSO を総当たりで見るも、見つからず。
他にも色々設定やらパスやらの問題かとやってみたけど、解決できず。

そして、今日ようやく発見した。
どうやら、tomcatの動作を高速化する JNI wrapper (Apache Tomcat Native Library) のうち、 tcnative-1.dll だけ xampp では導入されてないのが問題だと判明。
これが無いと、eclipse からの起動で問題が起こるみたい。

導入の詳細はこちらへ。


エラー2:
致命的: エンドポイントを初期化中のエラーです (文字化け)
致命的: Catalina.start
LifecycleException: プロトコルハンドラの初期化に失敗しました (文字化け)

もうね、エラー1で終わってくれればいいのに。
文字化けしてるからエラー内容が分からず、8080ポートを確認しても何も起動していず。
エラーをねちねち見てたら、一番上(おいw)にこんなことが。

 「今使ってるversionは1.1.9ですが、1.1.10以上を使うことを推奨します」

・・・(^ ^;)

つまり、さっき導入したDLLが古いバージョンだったみたいで。
最新版(1.1.14)を導入したら、あっさり動いてくれたwww


1週間かかって、出来たことは「eclipseからtomcatを動かす」それだけ。
・・・なんだろ、この疲労感は。
スポンサーサイト


Comments

Leave a Comment



10 2017
SUN MON TUE WED THU FRI SAT
1 2 3 4 5 6 7
8 9 10 11 12 13 14
15 16 17 18 19 20 21
22 23 24 25 26 27 28
29 30 31 - - - -

09

11


 
プロフィール

ひでたそ

Author:ひでたそ
Comment:
現役大学生で天文好き。
今日もどこかで、上を見ながら歩いています。

 
 
 
最新トラックバック
 
 
検索フォーム
 
 
 
ブロとも申請フォーム
 
QRコード
QRコード
 

Archive   RSS   Login

上記広告は1ヶ月以上更新のないブログに表示されています。新しい記事を書くことで広告を消せます。